Inability to transfer via bluetooth or wifi in Watch Face Studio

Hello everyone,
Someone has found a solution for those who are unable to transfer their Watch Face with the “Run on device” button. From my side, I always get the same result: My watch does not appear with the ip address and if I click on the name of my phone, a window appears with the instructions to connect my watch and my phone but it does not work. I am unable to enable usb debugging on my watch …

Another question: Is there another way to transfer our Watch Face to our own watch?

Someone can help me? My Watch (Galaxy Watch and Galaxy Watch3) My Phone: Samsung S21 Ultra


@richard_garant You know, of course, that WFS is used to support the Galaxy Watch 4 and will not connect to other models?

First off Download Galaxy Watch Studio (Tizen OS) not Watch Face Studio (Wear OS)

Run on Device does install on your watch. You have to manually delete it once it is installed.

When connected by WiFi the search doesn’t start at a low IP address number but if you go to your settings and click on Connections and the WiFi networks and select it it will show you the IP address and you add that to GWS in the + when you try to run on Device.

Be sure Wifi is Always on or Bluetooth is off when running on Device.

Galaxy Watch can be installed using SDBoverBT but Galaxy Watch3 and Acitve2 are newer version of Tizen OS that isn’t supported.

Read FAQ 23

Read the Tutorial for On Device Testing

Hope these help,

I’ll move this to the GWS forum.

Samsung Developer Relations

Are you sure?
It connects to my Gear S3 that I’ve had for years easily to the Samsung Watch Face Designer (and I just discovered to the Tizen Developer IDE.).
Just got a used Gear S3 with the exact same firmware and neither will connect to it and yes it is all on the same network, everything pings and works as expected.
Problem is the watch face designer refusing to connect even when I type in the IP.
Like R. Grant I just want to be able to load a known working watchface onto the other watch.

This may be because you either do not have Developer Options and Debugging turned on or you did not create a new Developer’s Certificate for that new Watch. Every watch or even after updated to a new Tizen version needs a new Developer’s Certificate.

But more likely you did not accept the RSA encryption key the first time you tried to connect. If you don’t do that it won’t ever show again without some manipulations SEE FAQ 23 on the steps to connect.

Samsung Developer Relations

Thank you Ron.
No RSA encryption key ever happened.
UNTILL: I rediscovered a way to turn on “Developer Mode” in addition to already having “Debug Mode” on.
The next time I tried to connect WFS to the watch the RSA encryption prompt appeared.
I haven’t found needing “Developer Mode” & “Debug Mode” enabled to be well documented…

That is on purpose (a security issue) so the general public doesn’t turn them on.

You’ve seen in the movies where a spy stands next to someone and clones their phone. Requiring the acceptance of an RSA Encryption key prevents that sort of intrusion.

Samsung Developer Relations