Key Alias

I just upgraded a Samsung Galaxy Watch Active2 to a Samsung Galaxy Watch4. I also downloaded and installed Galaxy Watch Studio Converter. I have a single watch face that I use for my own personal use that I created in Galaxy Watch Studio and when I try to convert it it wants me to enter a key alias and key password… I have no idea what that is.

You need to generate a certificate. See this link Build and upload from Watch Face Studio.  |  Android Developers for better guidance.

Thanks for the reply.

When I made the watch face I used on my Samsung Galaxy Watch Active2 in Galaxy Watch Studio I generated a certificate, do I need to generate a new one in Watch Face Studio?

The article you linked implies that I have a watch face already in Watch Face Studio which I don’t, I made the watch face I was using on my Samsung Galaxy Watch Active2 in the older Galaxy Watch Studio and what I’m trying to do is get that watch face on to my new Samsung Galaxy Watch4 and I thought that in order to do that I had to get that watch face into Watch Face Studio and that to do that I needed to convert it. The issue I posted about arose when I tried to use Galaxy Watch Studio Converter to convert my Galaxy Watch Studio watch face to Watch Face Studio format.

You need to create an Wear OS key you can’t use your Tizen distributor key.
click on Create a New Key it will open a dialog that you fill in and then create a password.

The keystore is a file with a .jks extension not a folder.

Key Alias is anything you want make it simple since you are working alone something like MyKey or Key01 which is the default

I use the same password as I did for my Tizen Distributor Certificate and Author certificate so I wouldn’t forget it. You can always generate a new keystore if you forget the password.

After you build just run on device. If you need help in setting up for debugging start a new thread.

Ron
Samsung Developer Relations

That did create a .jks file but now I get this message:

new_alias

I’m sorry, I thought they fixed that bug in an update. but it is still an older version on the download.

You will have to generate the keystore using Watch Face Studio. Make sure you create it in a different folder than the one you just created. Delete that folder.

Ron
Samsung Developer Relations

Clear the old dial before trying to install a new one.

Now I get the following warning:

wfs1

I just created that keystore password, is there a password protocol that maybe I’m violating?

I don’t think so. I’ve seen this error when the path was wrong (they made the path the folder not the .jks file).

But you should be able to just create a new one. Again use WFS not the converter tool to generate the keystore.

Ron
Samsung Developer Relations

First, thanks for your patience.

I’ve managed to connect my watch to WFS and import my watch face:

But when I try to Run on Device I get the following warning:

opr_too_high

It looks like you are using Watch Face Studio not the Galaxy Watch Studio Converter tool.

In any case the if you are using Watch Face Studio like in your image
click on the Always On tab to get to the AOD watch face
Below Run On Device are two window size arrows then below them a triangle
Click on the Triangle to show the preview window it will show what your AOD is
on the bottom of the preview Window are overlapping files click on that and it will open another image an that will show you what your OPR (on pixel ratio) is
To lower the OPR you can do one of two things
select components separately and lower their opacity
Select All and in the Color setting change that opacity box (right of the hex color) and lower everything.

If you are using Galaxy Watch Studio for Tizen it is a bit easier because the OPR shows in your Wonk window Lower the OPR in the same way and rebuild it then convert it. If the GWS project OPR is already below 15% lower it even more to less than 10%. I find that anything over 12% may not be under 15% when installed on the watch.

Hope that gets you started
Ron
Samsung Developer Relations

I read a lot of posts and articles and watched a lot of videos this weekend and I got it, I have 99% of my watch face working :slightly_smiling_face: So what is the 1% that’s not working you may ask? It seems to be a ubiquitous issue, one that I’ve seen you and others addressing many times in other threads (you are a patient man)- I can’t get a continuous HR on my watch face. I set the Project/Setting/Health/Heartrate Measurement Interval to 10 minutes and that seems to work sometimes, but even if it did work reliably every 10 minutes that’s not very useful.

I’ve seen some references to a new version of Watch Face Studio (I have Version 1.0.12) being released sometime in the future that might address this issue, do you have any news about that?

The watch I’ve been trying to get this working on is new and I have 14 days to return it and a large part of the criteria about deciding whether or not to do that was whether or not I could get a custom watch face working- looks like I’m keeping the watch :slightly_smiling_face:

Thanks for your patience and time.

That is an issue from that the WFS Team is aware of, It is a reason for a lot of play store rejections. Basically the issue is it displays the “Last Read Heart Rate” and does not instigate a reading
One thing to do is add an image over the heart rate make it zero opacity and then for Action tap measure heart rate. That isn’t idea, for example if you are biking or running to have to tap your watch to see your heart rate but it will work.

I’ve seen others watches that are able to select the Health Heart Rate in a complication I’ll see if I can find how that is done.

Ron
Samsung Developer Relatiosn

Hello - I am also having an issue with OPR too high. I did what you described but when I am in the ALWAYS-On window, changing the properties changes both the Normal and ALWAYS-ON components. Is there a way to only change the Always-ON components? I can’t seem to have a white background in Normal mode. I’m using Watch Face Studio.
Thank you.

I did what you described but when I am in the ALWAYS-On window, changing the properties changes both the Normal and ALWAYS-ON components. Is there a way to only change the Always-ON components?

Basically you need to have two different components one for AOD and One for Normal mode in the layers list on the right is an eye you can click for the component to be seen or not.
So take your Normal select all and group it call it Normal… Copy it… paste it call it AOD
Hide the Normal Group in AOD and hide the AOD Group in the Normal window.
Take the AOD group and and lower the opacity for the entire group. (you can see the effects if you view the Run Window as AOD
You have to expand the Run Preview to select AOD mode (the icon with half moon in it) You can analyze your OPR from that preview window.

I can’t seem to have a white background in Normal mode. I’m using Watch Face Studio.

Just make the bottom layer a white object. (change the saturation to 100%) But it is a bad idea it might drain the battery it may be more of a flashlight than a background. If you do force it to use a Theme Palette Color

Ron
Samsung Developer Relations

Geez - I definitely should have thought of that - lol.
Thank you so much Ron!