Login page for the distributor certificate is completely blank

Hi, I am trying to build a watch face I designed a couple of years ago, and, while I had a few minor hiccups along the way, I cannot get past the distributor certificate samsung account login page. It’s completely blank. I have read that this is because GWS relies on Internet Explorer 11, but because IE11 is deprecated, it cannot be run.

I have tried switching browsers, restarting my computer, connecting to my watch by different means, and I cannot get it to work. I even tried using the Wayback Machine to get the IE11x64 .exe off of Microsoft’s website, and it would not install because Edge replaces it.

What should I do? Is there a way to somehow bypass this certificate? I’m just going to use it myself, not put it on the Galaxy watch store.

Seems like I can’t use the newer Watch Face Studio for my GWA2. Could I use Tizen studio? (I have absolutely no experience with Tizen studio watch face making and it’s quite daunting)

Hi HenriHawk,

Welcome to the Samsung Developer Community.

Please check out this thread in Samsung Developer Forum. Ron has discussed this topic here. Following post is marked as solved so you can check this out.

Thank you,