No Device Found

Hi
Attached is the error message I get when I try to run the design on the watch (Galaxy 46mm)
Wifi and bluttoth are on my watch and phone, Debugging is on the watch, I’v tried everything…

I just recently struggled through this because the SDBoverBT via USB method stopped working due to updates. This made me have to resort to the wireless method.

I have Google Wifi in my house and it defaults typically to the best bandwidth connection which is on the 5ghz range. To use the Galaxy Watch Designer you HAVE TO be on the 2.4ghz range. There’s all kinds of weird ways to try and do that (and I tried some of them) but I was unable to connect.

So here was the fix! I used an old smartphone. I set up a hotspot on the old smartphone, connected my laptop, watch, and current smart phone to the old smartphone’s hotspot. At first it didn’t work, but a restart of the designer software and my watch and I received the authentication token shortly after!

Good luck and this should get it up and running for you.

Hi @nal1605543502,

If your watch got updated to Tizen 5 then try to connect through WiFi or as @jes1605713370 said. Otherwise follow the instruction here carefully and take a look at Q#23 at FAQs.

Azad