Non riesco a connettermi al mia Watch 3 dal app galaxy studio

Tizen 5.5 for Galaxy Watch3 and Galaxy Watch Active2 is not compatible with SDBoverBT. They keep promising a fix will be in an update but I’ve had two updates and no fix.

Until then you have to connect by WiFi.

I have to use SDBoverBT when on my work computer so I understand how inconvenient this is.

Samsung Developer Relations

Come faccio a connettermi tramite wifi?

If you are using Tizen Studio it is different but for GWS

Go to Settings → Gear info → About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Restart your watch make sure Debugging is on after the restart

For most people that can’t connect the problem has been accepting the RSA Encryption key

WiFi has two bandwidths 2.4 (Galaxy Watch is set for that) and 5 Ghz be sure that your WiFi is on the 2.4 Ghz band, many modems may have the same network for both.

In your watch settings go to Network make sure WiFi is always on or WiFi is Auto and you shut bluetooth off for debugging.

In Settings Network tap on the network and scroll down to get the IP address and make a note of it.

In GWS select run on Device a search dialog comes up click on the + sign and add your IP address OK it and it should find your watch in a short time.

You can then generate an Author and Distributor Certificate.

When you go to sideload the watch face to your watch you will need to accept an RSA Encryption Key immediately so be sure to have your watch active and observe it so that you can accept the encryption key. If you don’t see that and it has an expired or timed out error message that is the reason.

Samsung Developer Program