Progress Bar & Steps

I added a “Progress bar” from “Add Component” to a watch face. I then set the “Value” property (under “Range Setting”) to the tag “[SC]”. However, when I deploy this to an actual watch (Galaxy watch 4) then the progress bar always shows up as 100%. That’s despite the fact that I set the number of steps from 0 to 20k. So how can I get the percentage to show up on the component?

You can see this, may be this will help you.

use 0 then tag [SC] or ([SC]) when you are doing any math.

Be sure your project Setting has Step Goal at 20,000 too or it will fall stop sooner in the preview slider.

Finally you can use Step Goal not Step Count.

Samsung Developer Relations