Running BasicProject TV App - problem

So, I’ve got Tizen Studio 4.5.1 on macOS Catalina vs a QN55Q8FNB TV - which seems to be mfctrd mid/late 2018, and the chart tells me runs tv-4.0
The Studio 4.5.1 only installs with “TV Extensions 6.5” - no other choices (while Wearables, etc have numerous older versions).
When I try to run the BasicProject on the tv, I get a failure on package load - the 118012 error
also, in config.xml, I see required_version= “2.3”
I’ve tried creating a fresh author/distributor certificate pair, and also building a signed version of the app with that certificate selected in the Certificate manger.
The TV and the computer seem to be connected (tested w sdb command line)
What am I doing wrong? Do I need to find and install the 4.0 tv extensions and build against that?
Also, I see reference to “Permit to Install Applications…” with whichever device I want to install to (by right-clicking the device name). So far, can’t find a way to do this on the Mac with Studio 4.5.1

HI Marc
Did you create Samsung Tizen Author and Developer Certificates or Tizen Developer Certificates you nee to use Samsung certificates to run on Samsung Smart TVs

Have you checked your TV for an update? To see what version you are running?

Smart TV is not my area but I can look into this more if you don’t find any answers.

Samsung Developer Relations

Ron, I’m on my 2nd set of author/dist certificates, yes! no change in the problem. I am curious about 2 things - how to make sure my project is built with specific certs (I think it says go to certificate manager and make sure the one you want is ‘selected’) and I’ve seen some reports that suggest maybe I need to actually delete files on the tv first, if it got into a bad state or something, but although I’ve played with the sdb tool to check my connectivity, no idea what command to issue to delete anything that might have been previously partially installed. TV is up to date. Thanks very much for responding! If you have any further thoughts, please post. I am also wondering if maybe bc the sdk is tv-6.5 but the tv is older, I think 4.0 platform (2018), that could be causing a problem…

also - I’ve seen illustrated instructions showing a “Permit to install to TV…:” selection to be made, but on macOS, Tizen Studio 4.5.1 I can’t get to any option like that.

TV is in Developer mode. So that is not an issue.

Hold down the power button for 5 seconds to turn it off not just go to stand by mode or unplug it if you do need a permit to install that will force it. But I don’t see any mention of that in the docs. I only know that for Smart Watches.

Read these two pages again on Certificates and Connecting to Device I only know how to connect using device manager and on Windows. There may be other issues with macOS. I don’t know anything about the command line sdb commands.

I’ll see what I can find out but you may have to open a support request.

Samsung Developer Relations

Hi Marc,

Did you manage to fix this issue? I’m facing the same.
I thought it was MacOS certificate generator issue, but I did try with Windows then it is still replicable with the same error code.

Could you please suggest?


Hi Kenn,

Do you have the Samsung Certificate Extension enabled in Tizen Studio?

I think if this was recent that Samsung was updating its server security over the weekend and first of this week. Give it a try tomorrow.

Samsung Developer Relations

Hi Ron,

I’ve enabled Samsung Certificate Extension, I just tried yesterday before asking a question, also just tried again before answering this.

Still facing install failed[118012] from Tizen (only Partner) & Samsung (Public/Partner) certificates to SSSP6, but Tizen (Public) installing is fine.

I also have already added DUID to the certificate.


I wanted to provide some more data on this topic.
I am also having the same issue (the [118012] error code upon installing).
We are creating a Samsung partner cert for a hoisted app using the certificate manager GUI. We have the certificate extension installed and are using a privileged account to create the author cert. My other teammate is not getting this error code so it is likely something specific to my setup.
I don’t mean to take over this thread, I will start my own for support. I wanted to add my experience in case the extra data helped.

Thank you,

Use chrome, not firefox as your default browser when you log in for Distributor Certificate.

See this thread in GitHub

1- Application already installed with the same ID; uninstall the existing application first. This device may not support Tizen certificate signed widget files; try re-signing your widget using a Samsung certificate. If another Samsung certificate has been pushed to this device, you may need to re-push the certificate to the device.

2- Update: For some reason the certificate generator on one box seemed to be corrupt, so it did not provide the full “wizard” that allowed me to not only create a partner certificate, but also add the DUID of my device to it. So i used a different machine and i was able to create a partner cert (it properly prompted me to login to my samsung acct), and then associate the DUID. I then copied this cert to the box connected to the tv, and voila, after setting it to the default and then clicking “permit to instlal” from device manager, it seems to have worked as i was then able to install. It seems that the samsung dev environment is very fragile and quirky, especially when it comes to certs. I have no idea if there’s maybe a way to “reset” the certificate manager on the offending box so it clears any old credentials and let’s me do the proces, but anyway i seem to be unblocked.

Hope this helps.
Samsung Developer Relations