[Solved] Cannot re install certificates for Samsung TV 5 series

Hi guys.

Got an issue with Samsung TV 5 series (tizen 5.5), maybe someone knows how to fix it.
I have Tizen Studio 3.7. and Smart TV device which are perfectly worked together. I was able install and debug my app on the TV.
For some reason I had to reinstall my Tizen studio and, unfortunately all the certificates (author and distributor) were cleared from the PC.
After new installation I’ve made a new certificate and the studio tells me, that it is activated and I’m good to go with app installation.
After I press “Permit to install” it seems like the certificate was uploaded to the TV.
But during installation it fails with an error message [118,- 22].
From my side it looks like a TV did not get a new certificate.
Is there any way to resolve this issue?

Thanks in advance.

Look in the C:\User\USERNAME\SamsungCertificate\Tizen Certificates folder

Ron
Samsung Developer Program

Hi Ron.
This folder is empty as well.

Just to be sure you did generate a Samsung Tizen Distributor Certificate, Not a Tizen Distributor certificate? You can’t use that on a Samsung TV. You have to add the Samsung Certificate extension and enable it in the extension folder after you reinstall Tizen Studio.

Ron
Samsung Developer Program

yes. I generated Samsung certificate. It was working fine before I reinstalled Tizen studio (used uninstaller). As result all the certificates were deleted from the PC. I do not have any backups of certificates.
Samsung certificate extension is also installed. Please see the screenshot attached.

It looks like you have everything alright.

I talked to our resident expert and he said that you should be able to export them from
C:\tizen-studio-data\profile\profiles.xml
I uninstalled Tizen Studio from one of my computers and it seemed to have removed that folder too.

However, my .p12 files are in C:\Users\username\SamsungCertificate\ file

Ron
Samsung Developer Program

Unfortunately not in my case. :frowning_face:
This folder also empty for me.

Let’s imagine the situation when my PC completely died and I had to reinstall it.
How the certificate can be recovered in this case?
Is there any procedure?

Anyway, thank you for your answers Ron!

My advice is to delete the certificate profile you have now and create a new one with a new author and new Samsung Tizen Distributor certificate from Samsung.

Here is the deal with certificates.
Author Certificate, tells Samsung who you are and if you upload to the store and want to update the file later the author certificate must match the one. So we tell sellers to keep a copy of that on a second place. I keep mine on flash drive and second computer.
When you go to load on a device the author certificate can be different it won’t affect installation or at most you uninstall first.
Distributor certificate tells the device who you are and you an app can safely be installed. When you upload to the store the distributor certificate is replaced and it is a Samsung Distributor certificate.

You can not install an app on a Samsung device without a Samsung Distributor Certificate. If you created a Tizen distributor certificate and have that in the profile as well as Samsung (Tizen) Distributor certificate it will not allow you to install. Create a profile with just Samsung Author and Distributor Certificates.

Ron
Samsung Developer Program

First of all I would like to thank you for your answers.

Actually this is what I tried to do several times.

A new certificate was successfully created and uploaded to the TV (means Permit to install applications).

But, when I’m trying to run an app on the TV, Tizen studio returns me the following error message:
"
app_id[ESMP8SBFDH.MyApp] install failed[118, -22], reason: Security error : :Invalid function parameter was given:<2>
spend time for wascmd is [3684]ms
An exception occurred
(Installing the package… > Fail)
An exception occurred
Unexpected stop progress…
(9.31 sec)

However, when I create a new blank project it is successfully loading to the TV.

I already have no power to fight with this TV :frowning:

thanks,
Vitalii

You are probably going to have to uninstall the app manually. I think it may be the Author certificate mismatch that is throwing the error.

Ron
Samsung Developer Program

hi.
Just finished with re-installation.
According to the guide i’ve created both new certificates. But result is the same.
What I found strange here, that in "Problems tab" I see a message like "This privilege requires Partner level signing key " , it looks like the certificate was not loaded to the TV, but I did it in device manager!!!

Here is my new certificate.
image

Is there any place In the TV (maybe some engineering menu) where theoretically old certificate can be stored? Maybe an issue in the TV device, not in Studio?

Also on some website found this info:
118022
Not permitted to install this widget onto the target device with the current certificate. Either select a different certificate or ensure that your device unique ID has been added to the certificate whitelist. A Samsung certificate may be required for this device instead of a Tizen certificate.

maybe there is some whitelisting is needed for Tizen 5.5? ???

While Samsung Developer Program does not support Smart TV development if you open a support request HERE we can try to contact the Smart TV support team and see if we can get an answer for you.

I have an idea what it is and I don’t think it is a certificate issue as you said you can load example apps.

Ron
Samsung Developer Program

I already opened a request under https://seller.samsungapps.com
waiting for some answers.

An issue solved with a workaround.

In issue was related with APP_ID.
Somewhere in the app was cashed an ID of the app and the studio could not uninstall it.
What is strange that App with an old ID - ESMP8SBFDH doesnt exist in a list of installed apps.
So I cannot delete it from console and from studio as well.

Answer: Even if the studio returns certificate related error message (in my case it was [118 22]) it doesnt mean that cause is in the certificate.
Solution: Generate a new app_id in config.xml and app will start working with new certificate!

1 Like