[SOLVED] Author Certification not working

When I try to create a author certificate everything goes fine until after I sign into my Samsung account. It just gets stuck on the screen shown in the image below. I have waited hours with it stuck on that screen. It successfully generates the author.p12 file in the keystore folder, but when I try building it says my password is incorrect (which it is not). I have deleted the author.p12 file and created new certificates a few times to make sure. Why does it get stuck on the “Generating Author Certificate…” screen?

Hi @nickh12312,

Which version of Java is installed in your system?
Type java -version or javac -version in command prompt/terminal to determine which version of java your system reports.

The issue might arise due to incompatible Java version. See the Required Java version and check if your version is in the list. If it is not there, please install a supported version of Java and try again.


1 Like

Hey azad,
I had Java SE version 16 installed. I installed Java SE version 14 which that list says is compatible with windows version 2.0 of GWS and it is still giving me the same Generating Author Certificate screen.

EDIT: Nevermind. I didn’t have the java pathed correctly in the environment settings. It works now. Thanks for the help.

Great to hear the issue is resolved.