Unable install Tizen TV app on UE32M5520

Hi

I have Tizen Studio 3.6 (x64)

mobile sdk 5.5.
Wereable sdk 5.5.
mobile sdk 5
tv extension 5.5

My project works fine in "TIZEN WEB SIMULATOR APPLICATION (Samsung TV).

I created certificate for my TV via certificate manager.

TV is connected in device manager (with certificate associated).

When I try to install app from device manager this error occurs:

“org.tizen.sdblib.exception.sdbcommandrejectedexception closed”

I tried also putting WGT file in USB the directory but TV see empty directory.

In my config.xml required_version=“2.3”.

Could you help me?

Thanks

Stefano

Is the Smart TV in debug mode
Do you have the Samsung Distributor Certificate and only The Samsung Distributor Certificate in the Certificate Profile.

Those are the two most frequent issues but there may be some thing else if those aren’t it let us know.

Ron
Samsung Developer Program

I put TV in developer Mode.

What is debug mode?

I tried public/partner profile with the code of TV associated.

TV Is connected in device manager.

Besides if I open “open shell” from device manager in the console appears “close close”

Yes, Developer Mode, my bad.

I may be wrong but I don’t think you created a Samsung Distributor Certificate.
See the instructions in this site and be sure you created a Samsung Distributor Certificate and do not have a Tizen distributor certificate. The distributor certificate tells the device it is OK to run your app on that device and it has to be a Samsung distributor certificate.

Ron
Samsung Developer Program

I created “Samsung Distributor Certificate” (PUBLIC) with tv DUID associated.

When I try installing from device manager alway error
“org.tizen.sdblib.exception.sdbcommandrejectedexception closed”

occurs.

Stefano

I have to ask these questions although I’m pretty sure you did it right.

Do you have a Tizen Distributor Certificate in the profile along with the Samsung one? If so that can cause the rejection.
Did you rebuild all with the correct Profile not an old one?

In the meantime I’ll see if I can find another cause for this exception.

Ron
Samsung Developer Program

I have only Samsung certificate. I upload it from device manager.

I rebuilded project.

Otherwise can I install app from USB?

Hi,

I got same issue try by pass that doing dropdown menu Run ----> Debug As ----> Tizen Web Application in my case that way app install in my TV

Rgds,

Kari

I tried Debug As ----> Tizen Web Application .

I got this error:

"Installing the package… > Fail
Unexpected error occurred at the below step.
*** Installing the package...***
Tizen Web Application install failed. Please try again later."

I tried to install application via USB to my SAMSUNG TV but when I plug in usb pen drive, the installation process doesn’t start and I see only the pen drive connected.

I followed these steps:

To Run on TV, copy the .wgt file in USB drive in directory named userwidget . Plug in the USB drive in Tizen TV. TV will install the application. Go to Smart Hub-> My Apps and run the installed application.