Text Weather will not load

I’m working in build 1.8.1 and cannot get any of the weather options from Text to load. I get the normal warning message, but even if I load a brand new, blank template, not of the weather icons will load. Anyone else running into this issue?

This is probably one of two things.

Did you apply for and get the OpenWeatherMap.org license and put that license in the Preferences API section?

You can’t use Health and Weather in the same design.

Samsung Developer Program

Hi Ron,
Yes, I input my openweather API into the preferences but even with no other feature on the watch, the weather won’t load. There seems to be an issue with the buttons themselves as the description under one isn’t loading.

Perhaps I need to reinstall and see if that corrects the issue?

Restart you computer (don’t just shut down and start) and see if that makes any difference.

Also go to Edit - Preferences - APIs - and add your City to the location. I don’t think that matters but it is possible.


Samsung Developer Program

Hey Ron,
Tried both and still having the same issue. I uninstalled and re-installed the software and it’s still not letting me add any of the weather icons. Any other thoughts?

I think I spotted it in your image, it looks like everything is off a bit.
Do you have a Hi-Res monitor? if so you need to run 4k_support.reg in the C:\Program Files\Galaxy Watch Designer folder. Run it even if you aren’t sure as it won’t do any harm if you aren’t. Close GWD then double click on 4k_support.reg OK the options and then restart GWD you shouldn’t need to reboot unless you want to be sure.

Not having it causes the click areas to be off.

I hope that is the issue if not let me know.

Samsung Developer Program

That did the trick! Thank you!

Hi! I had the same exact problem. I coulndn’t add weather options in Text and the thermometer icon had no text too. I’m not too concerned about that, I just want to add the temperature text, but the warning keeps coming.

You were able to add the temperature text after you used the 4k reg fix? Not sure how that solved it. r-liechty_SDP says “Not having it causes the click areas to be off.”, but the icons and buttons seemed to be correctly clicked anyway.

WHen I ran the 4k reg, and even restarted the computer, the app still looked the same. I’m using Microsoft Surface Pro 3.

Oh it’s fixed now after I went to my display settings and changed the scale of text, apps and other items size to 100% (by default for my device, it was 150%.

Thanks for the pointers given here! Helped!