Watch Face Studio v1.4.13

I already tried that, it didn’t work.
I installed the previous version and it works, i’ll wait for a stable version of WFS.
Thank you for your help :slight_smile:

I also got it with WFS 1.4.13 and restarting my computer fixed it. I think I may have had a caching issue as I hadn’t restarted after installation.

Ron
Samsung Developer Relations

Thank you so much :slight_smile:

Yesterday I updated one of my watch faces. I just changed the text size. Today it’s rejected by Google Play because of a memory issue.

Here is the rejection reason: Watch face exceeds memory usage

Please advise. How can I solve this issue?

BTW I updated this watch face: https://play.google.com/store/apps/details?id=com.watchfacestudio.per018

1 Like

@Persona

It is probably the watch they tested on was full. It seems like Play Store reviews are a luck of the draw.
Are you using a png optimizer ( such as pngquant) on your images? That really decreases the watch face app size by over a factor over 100.

Good Luck if you have optimized images and still have a large .aab file size let us know.

Ron
Samsung Developer Relations

1 Like

It’s tempting to update our watch faces but I personally don’t suggest updating for complicated watch faces unless you have a backup that was build with 1.3.13. Once you build it with 1.4.13, you can’t open it with the lower version. You need to rebuild from scratch or park your watch face until fixed version arrived.
warning 1.14.13 to 1.13.13

1 Like

I hope that bug that doesn’t allow customization (sometimes) from the Wearable app will be fixed.

Even this version, the bug still seems to be there.

For example:

Thank you!

Bug Report.

There seems to be a delay in updating the AOD with the beta version.
A lot of times, the time tends to be behind 1 or 2 minutes later than the time shown on my phone.

At the very moment, my watch shows 10:23 AM while it is shown 10:24 AM on my phone.

I thought it was my bitmap fonts being too high in pixel size, but that doesn’t seem to fix the problem entirely.

I suppose this is because it’s a beta, but still something worthwhile to mention, since it didn’t happen on 1.3.13.

I got it on your MD 111 last weekend but not on the other MD Watch Faces. I reported this but I think it is not the Galaxy Wearable App but something else that is the issue. Reinstalling the MD11 fixed it. The Next time it comes up I’ll try restarting the Galaxy Watch(x) manager and see if that works.

Ron
Samsung Developer Relations

Thank you @r.liechty_SDR

I’ve noticed that this issue often happens when a watch face has many customizations (more than 8 “slots”).

Always on Display (Ambient Mode) does not have a timetick for seconds (to conserve battery life.) Since it can take a few seconds to transition from Normal mode to AOD mode there is probably about a 5 - 10% chance that this changed to a new minute on your mobile while it was going into AOD and still display the old time.
However it should self correct on the next minute.
If it is correct after the first minute then this is not abnormal. If however it stays 50 seconds behind that would be an issue.

Can you clarify that this time difference remains. WFS version should have nothing to do with that but I can report it if there is an issue.

Ron
Samsung Developer Relations

Sorry, I meant to say minutes! I’ll edit and correct.

It self-corrects after a minute, usually. But in the rare times, it started to correct itself after 2 mins.

I’ll do more testing on my end.

my thinking is it would go to AOD at
08:01:57
it wouldn’t complete the change to AOD until 08:02:03 but Display 08:01 for nearly a full minute.

I know there is a noticeable lag when the normal watch face display starts up and thought there may be one when it closes to open AOD.

Let me know if you notice it happening often.

Ron
Samsung Developer Relations

It is true that there is a lag when you switch from Active to AOD and vice versa

My issue is that it this happens even when AOD is active after a considerable amount of time.

For example, it was 4:00 PM.
It then changed to 4:01 PM on time.

When 4:02 PM comes, it doesn’t update.

When it’s 4:03 PM, the watch jumps from 4:01 PM to 4:03 PM.

It’s weird because it is inconsistent. Sometimes the AOD refreshes on time, and sometimes, it doesn’t.

One more question, Do you have any complications or animations being used in the AOD or is it just a minimal watch face?

Ron

There are complications used. The AOD version is the same as the active one.

That might be a factor can you report this or would you like me to do it?

Ron

Yes, this would be great if you could make a report.

Another thing to mention as well.
The watchface I am using both has a 1.3.13 as well, so I can compare between both the stable and the beta.

The stable version literally updates every minute with no lag at all.

For the beta version, the only things I’ve done, is to replace every SHORT_TEXT with a Circle Complication that can take both SHORT_TEXT and RANGED_VALUE complications.

This could be something worthwhile to mention. I am not sure if it’s the new complication format or the fact that it can now read the HR data from an app, that causes the AOD to refresh inconsistently.

Customized watch face… The time is not write at all… after about an hour of not touching my new galaxy watch 5 pro, the time isn’t correct. I’ve used galaxy watch studio in the past for my gear S3 with no problems…, but recently upgraded and got the galaxy watch 5 pro. Got the latest version of the new Watch Face Studio 1.4.13 and made my own custom watch face. Nothing to special. Simple layout etc and even used the sample clock arms,… tried a diff version (earlier version) of watch face studio and still time is off. Same with battery power %. Only way the time will correct is when i change to a different watch face then go back to my created one. I can’t find anything else online about this problem and kinda discouraging about getting my own watch face to simply show correct time and battery %. I’m lost at this point and sick of looking for answers. Please help if you know about this cause i haven’t heard of anyone having this problem. Not AOD… it’s the main time watch face.

The lag in updating time is apparently a known issue in the 1.4.13 beta version that is being worked on. My experience is very similar to yours with the watch time indicated being wrong.

I am hoping the next beta will be out relatively soon since designs from the 1.3.13 (stable) version can’t be imported into 1.4.13, so spending time on new designs in 1.3.13 will be re-spent to a degree when recreating the design in 1.4.13.

I think WFS is a great tool and the people working on the releases should be congratulated - looking forward to the next release!

1 Like

As @tgtech said this is a know issue with the Beta version of WFS on Wear OS 3. Unfortunately you can’t open the 1.4.13 Beta project with the WFS 1.3.13 release version but removing the Beta version and using the release version is your best option for a smooth running watch face.

The 1.4.13 Beta is designed for the next release of Wear OS. And I’m not sure if these issues are in the firmware or in the binary that WFS creates.

I do not know when that is released but I know that Galaxy Watch 4 and 5 will be updated to it when it is released.

Let us know how things go and if you have any other issues.

Ron
Samsung Developer Relations