Watch Face Studio v1.4.13

So I won’t have to update all my watch faces with the new version of WFS?

You probably should not update any current watch faces with the WFS 1.4.13 version. WFS 1.3.13 is the current release WFS1.4.13 is a beta release.

The long time watch face designers are so used to GWS always being a beta version we don’t notice it.

Samsung Developer Relations

1 Like


thank you so much for taking the time answering my questions!

Would you recommend to upload a new watch face created with 1.4.13 or should I still stick to the stable release to upload new watch face?


I can’t really duplicate what you are doing for the Complication boundary but I think this is FAQ 13

In Watch Face Studio, complications must be implemented independently. They cannot be grouped with or be part of another element. Complications can only contain elements within them.

Samsung Developer Relations

Hi, I can no longer connect to my Fossil Gen 5 (WearOS 2) watch, is it no longer supported? Cannot seem to find information about this, only that WearOS 3 is now targeted (but not the minimum I suppose?)

I tried connecting via Wifi and Bluetooth(with phone connected via USB)

BT is no longer supported because the Wear App is not supported on Wear OS3. If you can connect with WFS 1.3.13 I would back down to that. WFS 1.4.13 is beta and seems to have some issues with the older OS version.

You cannot open any project that was updated by WFS 1.4.13 beta with WFS 1.3.13

Samsung Developer Relations

End users always think that any flaw is the developers fault. I don’t think there are any Wear 4 devices I’d only publish watch faces built with WFS 1.3.13 for now.

Side note: ratings are used by online stores as a factor for placement of the product including Play Store.

Samsung Developer Relations

1 Like

Many thanks to the dev team! :blush: :+1:
Just one small thing to report, I don’t know if it is a bug or if it is intended.
In version 1.4.13 the screen captures from the preview are saved at 450x450 25ppi instead of 450x450 72ppi. It is not a big thing so if is the new format I will change my Photoshop templates.
Thank you.

Just checking the loop feature. You cannot unloop in this new version. You have to re-upload the image and set up a loop. When applied to watch, loop works only a few minutes after the watch entered AOD and switch to active mode. Loop will work again when you switch to another watch face and switch back. I hope this will be fix soon. Anyway great job WFS team for this new version at least we know what to expect in the near future.


Hello everyone!
Is anyone also having this same problem?
Screenshot 2023-05-14 001501

Turn off Bluetooth, only WLAN on

I already tried that, it didn’t work.
I installed the previous version and it works, i’ll wait for a stable version of WFS.
Thank you for your help :slight_smile:

I also got it with WFS 1.4.13 and restarting my computer fixed it. I think I may have had a caching issue as I hadn’t restarted after installation.

Samsung Developer Relations

Thank you so much :slight_smile:

Yesterday I updated one of my watch faces. I just changed the text size. Today it’s rejected by Google Play because of a memory issue.

Here is the rejection reason: Watch face exceeds memory usage

Please advise. How can I solve this issue?

BTW I updated this watch face:

1 Like


It is probably the watch they tested on was full. It seems like Play Store reviews are a luck of the draw.
Are you using a png optimizer ( such as pngquant) on your images? That really decreases the watch face app size by over a factor over 100.

Good Luck if you have optimized images and still have a large .aab file size let us know.

Samsung Developer Relations

1 Like

It’s tempting to update our watch faces but I personally don’t suggest updating for complicated watch faces unless you have a backup that was build with 1.3.13. Once you build it with 1.4.13, you can’t open it with the lower version. You need to rebuild from scratch or park your watch face until fixed version arrived.
warning 1.14.13 to 1.13.13

1 Like

I hope that bug that doesn’t allow customization (sometimes) from the Wearable app will be fixed.

Even this version, the bug still seems to be there.

For example:

Thank you!

Bug Report.

There seems to be a delay in updating the AOD with the beta version.
A lot of times, the time tends to be behind 1 or 2 minutes later than the time shown on my phone.

At the very moment, my watch shows 10:23 AM while it is shown 10:24 AM on my phone.

I thought it was my bitmap fonts being too high in pixel size, but that doesn’t seem to fix the problem entirely.

I suppose this is because it’s a beta, but still something worthwhile to mention, since it didn’t happen on 1.3.13.

I got it on your MD 111 last weekend but not on the other MD Watch Faces. I reported this but I think it is not the Galaxy Wearable App but something else that is the issue. Reinstalling the MD11 fixed it. The Next time it comes up I’ll try restarting the Galaxy Watch(x) manager and see if that works.

Samsung Developer Relations

Thank you @r.liechty_SDR

I’ve noticed that this issue often happens when a watch face has many customizations (more than 8 “slots”).

Always on Display (Ambient Mode) does not have a timetick for seconds (to conserve battery life.) Since it can take a few seconds to transition from Normal mode to AOD mode there is probably about a 5 - 10% chance that this changed to a new minute on your mobile while it was going into AOD and still display the old time.
However it should self correct on the next minute.
If it is correct after the first minute then this is not abnormal. If however it stays 50 seconds behind that would be an issue.

Can you clarify that this time difference remains. WFS version should have nothing to do with that but I can report it if there is an issue.

Samsung Developer Relations