Watch Face Studio v1.4.13

Sorry, I meant to say minutes! I’ll edit and correct.

It self-corrects after a minute, usually. But in the rare times, it started to correct itself after 2 mins.

I’ll do more testing on my end.

my thinking is it would go to AOD at
it wouldn’t complete the change to AOD until 08:02:03 but Display 08:01 for nearly a full minute.

I know there is a noticeable lag when the normal watch face display starts up and thought there may be one when it closes to open AOD.

Let me know if you notice it happening often.

Samsung Developer Relations

It is true that there is a lag when you switch from Active to AOD and vice versa

My issue is that it this happens even when AOD is active after a considerable amount of time.

For example, it was 4:00 PM.
It then changed to 4:01 PM on time.

When 4:02 PM comes, it doesn’t update.

When it’s 4:03 PM, the watch jumps from 4:01 PM to 4:03 PM.

It’s weird because it is inconsistent. Sometimes the AOD refreshes on time, and sometimes, it doesn’t.

One more question, Do you have any complications or animations being used in the AOD or is it just a minimal watch face?


There are complications used. The AOD version is the same as the active one.

That might be a factor can you report this or would you like me to do it?


Yes, this would be great if you could make a report.

Another thing to mention as well.
The watchface I am using both has a 1.3.13 as well, so I can compare between both the stable and the beta.

The stable version literally updates every minute with no lag at all.

For the beta version, the only things I’ve done, is to replace every SHORT_TEXT with a Circle Complication that can take both SHORT_TEXT and RANGED_VALUE complications.

This could be something worthwhile to mention. I am not sure if it’s the new complication format or the fact that it can now read the HR data from an app, that causes the AOD to refresh inconsistently.

Customized watch face… The time is not write at all… after about an hour of not touching my new galaxy watch 5 pro, the time isn’t correct. I’ve used galaxy watch studio in the past for my gear S3 with no problems…, but recently upgraded and got the galaxy watch 5 pro. Got the latest version of the new Watch Face Studio 1.4.13 and made my own custom watch face. Nothing to special. Simple layout etc and even used the sample clock arms,… tried a diff version (earlier version) of watch face studio and still time is off. Same with battery power %. Only way the time will correct is when i change to a different watch face then go back to my created one. I can’t find anything else online about this problem and kinda discouraging about getting my own watch face to simply show correct time and battery %. I’m lost at this point and sick of looking for answers. Please help if you know about this cause i haven’t heard of anyone having this problem. Not AOD… it’s the main time watch face.

The lag in updating time is apparently a known issue in the 1.4.13 beta version that is being worked on. My experience is very similar to yours with the watch time indicated being wrong.

I am hoping the next beta will be out relatively soon since designs from the 1.3.13 (stable) version can’t be imported into 1.4.13, so spending time on new designs in 1.3.13 will be re-spent to a degree when recreating the design in 1.4.13.

I think WFS is a great tool and the people working on the releases should be congratulated - looking forward to the next release!

1 Like

As @tgtech said this is a know issue with the Beta version of WFS on Wear OS 3. Unfortunately you can’t open the 1.4.13 Beta project with the WFS 1.3.13 release version but removing the Beta version and using the release version is your best option for a smooth running watch face.

The 1.4.13 Beta is designed for the next release of Wear OS. And I’m not sure if these issues are in the firmware or in the binary that WFS creates.

I do not know when that is released but I know that Galaxy Watch 4 and 5 will be updated to it when it is released.

Let us know how things go and if you have any other issues.

Samsung Developer Relations

I missed this earlier were you saying that these issues happened with WFS 1.3.13 as well? If so this may be a caching issue if you are using the same project name. I’d suggest you uninstall the watch face and hold down both buttons until it says rebooting also restart your computer to clear any WFS caching.

Then rebuild your WFS 1.3.13 project and run on device If it still has an issue let me know.

Sorry about missing that sentence earlier

Samsung Developer Relations

K thanks for the quick response…, i’ll uninstall …, and install 1.3.13 again (rebooting pc and watch) and start from scratch. I made another watch face last night with digital numbers and is working fine. But i usually prefer the clock arms. I’ll let ya know later tonight how it goes…, thanks again for the help.

If you see decreased battery life after installing a watch face it is most likely because you didn’t turn off the ADB debugging after you installed it. While it doesn’t continually connect (it used to kill the battery in 24 hours) it does check for a network still and uses about25% more battery than normal.

Also remember how bright your watch face is makes a big difference. This is for both Analog Hands and Digital Readouts but I think the fonts handle it a bit better.

Samsung Developer Relations

It’s working great now…, smooth and time is correct now with the analog clock. i always leave the wifi off cause it drains the battery fast. And battery % is correct as well. Thanks for the help. Hopefully they’ll get the bugs fixed in the never version.

I immediately tried v1.4.13, that’s my experience:

  • First, i started with WFS recently, and i immediately updated from the stable to the beta version. And that’s my fault, I should’ve realized that it’s a beta. I reverted to the stable version, but I have to recreate my watchfaces from scratch. :worried:

  • Any watchface compiled using WFS 1.4.13 is rejected by Google for “memory usage”. I uploaded a simple analog watchface with a single complication and it got rejected (multiple times, i tried 3 times to make sure it wasn’t a false positive and also appealed). I think that the memory limit is 4MB, because i removed the complication and the .aab was accepted (before it was 4.5MB, after 3.8MB)

  • The resulting watchface feels a bit more buggy, and that’s pretty normal

When is the new stable or beta release scheduled? Anyway, thanks for your work!

@r.liechty_SDR Maybe there should pin post on the forum about not recommending using WFS 1.4.13 for Play Store publishing.

  1. aab created with WFS 1.4.13 and approved by play store can not be updated again (looks like some issue on Google Side when publishing app with native code)
  2. memory usage issues (rejections)
  3. downloading WFS 1.4.13 watch face is impossible from Wear OS Play Store (installation asks for permission but there is no button to allow - again, looks like Google Play issue)

I didn’t know you can’t even install the watchfaces developed with the latest version. That’s a major issue, and it should be pinned somewhere, as you said. Lesson learned, I won’t try any beta version :grin:

A release version of Watch Face Studio v 1.4.x is in the QA testing cycle and hopefully released very soon.

The issue with the rejections by Play Store are in Play Store and we have informed them of the issue.

Samsung Developer Relations

Hi, today I got same problem and rejected watch face due to exceeds memory usage, is there any solution, please advise. Thanks.

Did you optimize (Compress) your images that will make a big difference. What is the size of your .aab file? There are several .png optimization tools such as pngquant that can dramatically reduce the size of a .png file
Please check the requirement of Google Play for Watch Face Format.
Also refer to this guide for optimization.

Samsung Developer Relations

1 Like