Connection Error

connectiontimeout

Whenever I try to get certificate by connecting samsung account In tizen studio’s certificate manager, It generate the connection Timeout exception error.

This seems to happen every so often and usually trying another day works.

Also, make sure your default browser is Chrome and not Internet Explorer or firefox. Andi it might help if you log into the seller store before you try.

If you can’t get it after a couple days of trying let me know and I can look into it more for you.

Ron
Samsung Developer Relations

I’m also not able to acquire new Author Certificate through the Galaxy Watch Studio. It says “Timeout” after authenticating.

My default browser is chrome and the error still happens…
I can’t get certificate now.

Hi,

I have duplicated this and will escalate it to the Seller Portal Ops team.

Ron
Samsung Developer Relations

Same in this side, I am trying a certificate for Samsung tv and I have the same error, any update ???

This is blocking our development, please fix ASAP!

It is starting to look like this is an issue with the Tizen Development team not the seller portal. It was escalated to them Friday.

I should be copied on any email and will post when I get a response.

Ron
Samsung Developer Program

hi, same issue here. Thanks for the update. Is there any other way to create a certificate and just import it?

Author Certificates can be generated to tell Samsung who you are and are portable.
However Distributor Certificates tell the device it is OK to run your app and as specific to the device. So you have to create a separate one for all Tizen Devices and they may be portable to different machines but are not portable for other devices.

Ron

Excuse my ignorance but, there is someone actually working on this problem, I mean, it’s been several days of this and still the same error.

Hi,
Pls fix this issue ASAP.
This problem has been going on for more than a week and still has not been resolved, seriously blocked the development progress of all Tizen developers!
Thanks.

3 Likes

Honestly this is unheard of in other SDKs or development platforms. It’s been a week?

If the problem is on the certificate issuer having different message payload upon auth, then can it be reverted?

Later on, push updated IDEs that can handle both old and new protocol.

Looks Like it’s fixed, thnks

The issue has been resolved. Please try and let me know if you still face the same issue.

Thank you,
Iqbal
Samsung Developer Program

still an issue for me and others reading the several threads on this.

Same issue here. Hope this will be really resolved soon, since it looks like I’m not the only one still having the same problem.

Still getting the same issue when trying to create new certificates (author and distributor) macOS 12.2.1

Any workarounds?

+1 This has stopped all Tizen development for our company.

6/28/2022 9:00 -8 GMT
Creating Author and Distributor Certificates worked for myself and another co-worker (both remote) this morning.

Ron
Samsung Developer Relations