Distribute Certificate Times Out

When attempting to make a Distribute Certificate to be able to test my watch face on my physical watch, Galaxy Watch Studio gives me a timeout error when I attempt to create it.

I’ve attempted using different WiFi connections in case it was an issue with my firewall or something, but that doesn’t seem to have fixed it. I’ve restarted both the app and my computer, and I have already

After a bit more poking around, I’ve confirmed this is happening on creating Author Certificates as well

Hi @josefernandes505,

Can you please submit a Developer Support request?

Please add detail information along with the screenshots.


Hi. I’ve got the same issue here.
I’ve tried it with a different account but it still doesn’t work. Tried it without anti virus, without PiHole, still doesn’t work.

If you are running Windows 7 this will happen unless you enable the 64bit Internet Explorer. You don’t need to run IE but you need it for a .dll that it adds.

If you are Windows 10 or Mac and get the time out error when creating the Author Certificate then it a network issue either on your end or Samsung’s try again maybe at a non peak load time, like early morning.

Samsung Developer Relations.

I am using Windows 10 Pro x64 and Galaxy watch studio app. I am unable to renew my certificate. I cannot create a new certificate (timeout). The firewall turned off. I changed Internet channels. NOTHING HELPS!

i have same problem.Timeout error always…

갤럭시워치 스튜디오 연결방법 숙지후 프로그램까지 다 깔았지만 권한인증에서 삼성계정 로그인만 하면 시간오류로 진행이 안되는데 다른장치 및 웹에서는 삼성계정 로그인이 잘만되는데 워치 스튜디오에서만 로그인하면 먹통인지 조언구합니다.

I cant make cert same problem above. plz make solution or notice anything.

Luckily, I am not the only one having the same issue. It’s bit frustrating because I tried all ways, but it seems like there’s a system error on the other end. Can anyone from developer community help us sort this out.

It is an internal server error and I’ll see what I can do.

Samsung Developer Relations

Buenas tardes.
Parece que esto sigue igual.
¿alguien tiene alguna novedad?

Se está trabajando en el tema.

Relaciones con desarrolladores de Samsung

Experiencing same issue here

1 Like

Hopefully this is fixed now. If you still can’t connect give it another day. They are working on it.

Samsung Developer Relations

1 Like

I am having the same problem, it does not create the certificate showing the timeout error

now it is now “Read timed out”

Why is Samsung’s approval needed to install apps on our own hardware anyways?


No change yet. Same issue still persists. Will try again tomorrow.

Ahora me ha funcionado.
Gracias a los que os habéis interesado por arreglarlo.
Saludos a todos.

Hi All,
The certificate issue has been resolved. Please check at your end.