[Guide] connecting watch to wfs

Final note for better success turn of bluetooth as watch tents to switch the wifi to bluetooth aggressively.

Or put watch on charger…its seem its due to battery optimisation.

Addition tip this is to revoke debugging authorisation. And forget any previous pairings. Before trying again

Hello,

I am using Watch Face Studio (v 1.5.7) to make a custom face for my Galaxy Watch 4, running on Windows 11 on my PC.
Now I have a design ready that I want to “Run on device”.

First, I have connected my watch to WiFi on my router, and have successfully downloaded a software update to the watch, so I know the watch is definitely connected. It now has system version 13.

I have followed to the letter the instructions shown in the very helpful diagram provided by “Knightwing” on:
[Guide] connecting watch to wfs - #2 by Knightwing
Everything is as on the diagram,and I have copied IP address, IP port, Pairing code, and Pairing port onto the “Add device” panel.
But when I click on OK I get the message “No compatible devices”.

It seems that the PC and the watch are both connected to the router, but are not able to connect to each other.
Can you advise on what I should do ?

Hi, is your pc on wired or wireless?
Did you wait for awhile sometime its takes a min or two for your watch to appear on wfs

Hi, My PC is on wireless.
I have waited about 10 mins, but with same result.

Hi , sorry i am on gmt +8 so fell asleep. anyway do you have a firewall installed in your windows.

Did you get any messages about wrong input?

E.g, Failed to pair a device (ip: xxxxxx) Please need the data on the device or check your input,

does your watch show something like this?

paired

if not means for some reason its not paired and connected correctly

Hint: turn off bluetooth on the watch while doing this

Hi, My apols also for slow reply – it’s morning here now.

I have turned off firewall and turned off bluetooth on the watch and tried again, but still does not work.

There is no error message – the “Connected Devices” panel on WFS just says “No Compatible Devices”.

On the watch under Paired devices (ie as on your picture) it shows my PC name:
kenar@DESKTOP
and below that it shows “Currently connected”

Hi tagged @r.liechty_SDR see he can answer u. Beyond me already, looks like for u everything checks out as u follow guide correctly but its not working.

But is your watch and laptop in the same band 5gz or 2.5gz?

Go to your Developer Options
Turn on vibrate when connected to device
scroll down past the wireless debugging
Revoke Debugging Authorizations and do that.
My thought is that you for some reason denied them by accident at one time
Then do the wireless debugging at some point you need to OK debugging again that may be the issue.

Hope that was it, it is very easy mistake to make.

Ron
Samsung Developer Relations

Hi Ron,
I have tried the steps you suggest.
Turned ON vibrate when connected to device.
Clicked on “Revoke Debugging Authorizations”, and clicked OK.
(I’m a bit puzzled as to why I should revoke them; I would have thought I should enable them ).
Made sure Wireless Debugging was ON.
Paired devices shows “Currently connected”, as I say above.

But still no joy – same result as before.

Hi @kenarton10 did you do a forget to the previous pairing before u retry? And is your pc and watch on the same band as i ask before?

Probably u may need to restart your watch…

Click “kenar@DESKTOP” if its there and click forget.
It will disappear. Then retry the steps

@r.liechty_SDR it didnt work for him.

P.s can you try with adb commands line? See any errors

Hi,

My PC is on 5GHz, not sure what the Watch4 is on, but I guess you will know that.

You say to restart the watch; I could only find “reset” but I assume that is the same thing, so I have done a reset – it took several minutes, and does seem to be a restart.
Having restarted, I have lost the Developer options, and cannot recall how I installed them previously. Can you help me with that, and then I will be able to get back to trying out your suggestions. Thanks.

Hi again,
I have managed to get Developer Option enabled, but now have to re-connect to my router. i have to enter a 16 char password, which is very trying with the tiny keyboard.
Will get back soon.

Hi again,

So I have done a restart, and have now re-connected watch to the router.
I have clicked on “forget”, as you suggest.
Still same result as before.

I have also managed to get ADB installed. I open a command window, go to the adb folder, and enter
“devices”. The last device listed is the IP address and port for the watch, which seems to indicate that my PC can see the watch.

Hi, got to close your wfs , end any adb session.
Try running adb from

C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window

Instead,

Calling pair and connect command

Adb pair “pairing ip:port”
Type pairing code when prompted

If sucess

Do adb connect ip:port

Hi, Just got this – late here now.
Will try it tomorrow morning.

I have 2 suggestions, if adb command prompt works.
And u still dont see it in wfs.

  1. try using the command prompt to side load the apk

Disclaimer: if for some reason the apk is really not compatible with your watch it might break/spoilt/break your watch. So its at your own risk.

  1. request a bug report and sent a log file to support
    C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main.log

Let me know which option u would like to take. I can direct u to direction.

Hi,
Progress! I think I’m nearly there.

I have followed your tips on using adb, and have successfully connected PC to watch.
In WFS, when I click on Run on Device, the link appears in the panel, I click on it and download starts. After about 1 min it indicates launch completed.

On the watch I can now see a new face has been added to my favourites.
But it is completely blank!
I suspect this is because I’ve created the face using the “Always On” tab. When I switch to the “Normal” tab it is blank.

The WFS guide says: “Once you are happy with your always-on watch face, continue with the rest of your design by switching to normal mode”.
This suggests I ought to see what I have already designed when I shift to the Normal tab — but I don’t.

So the question now is: How do I get my Always on design into Normal mode ?

Hi Again,

Solved latest problem. I needed to click on all layers in normal mode to make them visible.
Have now downloaded to the watch, and my face design appears as it should.
Which is great, BUT:
It shows the correct date, but the wrong time!
The time is way out – approx 4 hours.
For time setting, I have switched off Automatic, and set it manually.
Other faces show the correct time.

In your project setting for the Time. Check the Timezone setting and use Sync with device You may have mistakenly set it to some other time zone.

image

Ron
Samsung Developer Relations