Latest WatchFace Studio 1.1.9 WearOS Status and Supported devices in the catalog Problem!

The dial from this version, getting into the store, gets the status active immediately after loading, however, in supported devices, it is under endless verification.


1 Like

I don’t think it’s about WFS 1.1.9.

I have published a watch face (today) with WFS 1.1.9 and have not detected this issue.

I think this is an issue on the Play Console.
I have heard that other developers are having the same problem.

Having the same problem & it’s frustrating. I wrote about 8 support tickets, they still beat me to wait. They can’t understand what I mean. Today I even opened a new developer account to see if there was an error in my account or application and the new account when releasing test app showed “pending review” for Wear OS (which is good) so the problem is definitely related to the developer account.

@HYSTEREO Looks like our dev accounts are somehow corrupted. I’m getting active status instantly too :frowning:

The worrying thing is that it is very difficult to communicate with a team on these issues. You always get the same prepackaged answers which solve nothing in most cases. Very frustrating. Seller Portal is light years ahead on this side.

3 Likes

I have the same problem.
Funny thing is that the store app does not install it on the watch, but it is installed on the watch through a web browser.

Yes, noticed that too. Also, this only works for GW4 devices.

Has anyone found a solution to this issue? I think it needs to be highlighted because developers cannot be left on the high seas like in this case. Here there are people who work for their own interest and for the development of Wear OS powered by Samsung.

I’ve tried deleting all watches from the catalog, then uninstalling WearOS under the advanced tab. Then re-enable the Samsung watch in the catalog, and re-enable WearOS. It will still be in the “active” status. However, thanks to such manipulations, my dial was checked … True, I got rejected due to problems with the heartbeat lol

1 Like

Hi. So your device catalogue is showing something other than “pending review” after these manipulations ?

I’ve created multiple tickets & explained this as good as I could. This is the latest, most promising reply

Hi Tomas,
Thanks for your patience while we look further into your issue/concern.

I’ve documented your issue and escalated it to our technical team for further investigation. Our team is working to resolve this issue for you as soon as possible.

I appreciate your patience and I’ll let you know the moment I have an update.

3 Likes

Thank you for update!

I have the same problem.
Also, there are a lot of cancels for some reason. :thinking:
Anyone else having the same issue?

Didn’t work for me. Watch face was reviewed in about 6 hours. 31 devices - excluded manually. 8 Samsung devices (watches) - in review :confused:

Yes, the same problem I had too.

now it’s the weekend, wait for weekdays) I’ve already ruined this dial 3 times for verification, each time they return it)

That’s crazy… :confused:

I don’t think this is Google’s problem.
We’ll all remember that we had a hard time with heart rate problems before. But the WFS update solved it.
I think there was a problem as the WFS was updated again this time.
Of course, this is just my guess.

Same issue here getting instant ACTIVE status on anything I publish with new WFS.

Is it worth me trying the older release will that fix this issue ?

Nope. It’s some nasty play console - dev account issue / error. I’ve created new dev account only to test this & both watch faces created with 1.1.9 & 1.0.12 are showing "In review"

Why is not it possible that everything works without error. Since the beginning there are always errors, either with the WFS or Google Play account. That annoys me! :rage: