Samsung Author Certificate Network Error

I am trying to generate an SAMSUNG AUTHOR CERTIFICATE, for an app I am working on.
At step 3-2, I was asked to sign in into my account, which I did successfully.

After I signed in to my account, I get this NETWORK ERROR

This is my first suck certificate. I’m new to Tizen Studio. Yet I have had this issue over 2 months now, I can’t find any solution.

  • Yes I tried Developers Support, I haven’t find any solution yet.

  • Yes I updated recently: “Tizen Studio->Package Manager you could see the update option for Extension SDK-> Samsung Certificate Extension”

*Version of Tizen Studio:

*Operating system information:

*Creating a new author certificate, NOT updating the existing one

it looks like this is a network or firewall issue on your end. Are you on a VPN I get the same error from Samsung VPN when I’m at work.

Samsung Developer Relations

Hello @r.liechty_SDR , thanks for responding.
No I’m not using any VPN.

What is your default Browser if it isn’t Edge or Chrome change it to that and see if that works.

This may not be your problem at all but a problem connecting Seller office to the certificate server. This happens more frequently that I’d like. It usually sorts itself out after a couple days. If it doesn’t then open a support request with the Seller Office

Samsung Developer Relations

I set my default Browse to both Edge and Chrome and tried. Both times same issue.
What do you mean “…connecting Seller office to the certificate server.” What is “Seller office”?

It sounds like you are doing things correctly at your end

I’m sure you read all the instructions here

The Author Certificate is created by the Smart TV Seller Office and it sends a file to your computer and it looks like Virus checker or something is not allowing that to happen. What should come up is a notice saying where your Author Certificate is located. As I look at this that is where the network error pops up.

After you get an Author Certificate the Seller Office connects to Tizen to generate a Samsung Tizen Distributor Certificate but you don’t get that far.

You may have to add * to your safe internet sites
Internet Options
Trusted Sites

If you have a virus or malware protection you may need to tweak that.

Hope this helps

Samsung Developer Relations

Thanks for your help.
Yes I read all the instructions.

Since I can’t add ‘*’ to Internet Options->Security->Trusted Sites I added 'https://*

Still having same issue.

I’m not able to test my app on a smart tv. Is there any other way, without using an author certificate, am I able to load my app on a smart tv?

I believe you can use a Tizen Generated Author certificate but you need the Samsung Distributor Certificate to run on Samsung Devices.

Did you look for an answer in the FAQ-Q/A under the most appropriate topic on the Smart TV Seller Office site

If you don’t find a solution there then sign in and open a Smart TV Seller Support Request .

Samsung Developer Relation

Well, I sign in to Smart TV Seller.
Unfortunately, I’m unable to create a request due to the fact that you need to have an app on seller to request any support. I don’t have an app yet. I’m unable to test it.


This has got to be an antivirus program you have running or a non-writeable path.

After it creates a Author Certificate it sends it back to you and it appears your computer is blocking that from being installed on your computer.

the folder you selected could also be write protected
Where do you have Tizen Studio it should be in C:\Tizen Studio
Where do you say to put your certificate It should be in C:\users\username\SamsungCertificates or wherever you specified.

Is there any non English characters in the path that could be the issue

Did you disable any virus protectors when you tried to create the certificates

You only need an Author’s certificate before you can create a Distributor Certificate and you need the Distributor Certificate to run on device.

Samsung Developer Relations

Yes my Tizen Studio is in fact, in C:\Tizen Studio
I didn’t get to choose where to put the certificate. I haven’t reached that option.
I got the error before that.
No non English character in the path.
No I don’t have any virus protectors to disable except windows firewall.

do you get to the captcha verification?


Also can you check your Samsung account and make sure it is the same as your Seller Account. If you have 2 step verification turn on in either the seller portal or Samsung Account It could be you aren’t getting that to proceed.


Yes I get a captcha verification sometimes
No I have not turn 2 step verification on.

I think it is just blocked on your end. I can’t find anyone else reporting this issue. The only thing I can think of is you have a 32 bit or not supported version of Java Runtime installed and that is overriding the JRE built into Tizen Studio

At command prompt
Java - version and see what it says,



If it is in System32 it isn’t the 64 bit version of Java
Uninstall it and install the 64 bit version
not the x86 version but the 64 bit version

I think that should fix it (hopefully) if you do need the 32 bit version for some other software, let me know there are ways to work around it.

Samsung Developer Relations

I uninstalled Java, and download 64bit version and installed it.

Alas… same issue

Try this,

Can you create an Tizen Author’s Certificate? that may help determine if this is your system or Samsung system.

Do you have access to a different computer on a different network?