World time shows 24:mm instead of 0:mm

I’ve added a short text world time complication, and set the timezone to Adelaide. The time shown when it’s just past midnight there is 24:mm instead of 0:mm.

This is on WFS 1.4.20.

I can’t see any tags that I could change to change the display format. Feel I must be missing something?


Use the Tag [HOUR_0_23_Z] with zero or [HOUR_0_23] without zero


I understand that would fix it, but in which field is the tag held, in the properties of the complication? I just can’t find it!

A… I read wrong. I thought you wanted to show a digital time. Unfortunately I do not use version 1.4.20. I think you cannot affect the format a complication, the data will come directly from the watch/app. Please show screenshots from WFS.

1 Like

I’ve created a test case now. Would be useful to get Ron’s (@r.liechty_SDR) input and I’ll create a bug report if it’s not just user ineptitude!

The test case just has a ‘Line’ complication set as ‘Fixed’ with the default provider being world clock. It displays fine in the WFS preview window but in the hour after midnight in the selected timezone the watch it displays 24:xx as the time. I attach a screenshot saved from my GW4 when I had the time zone set to Hawaii, which happened to be just after midnight there…


One other thing. In WFS 1.4.20, WFS sets the “Text” field of the complication to be the time, and the “Title” field to be the Time zone label, but on the actual watch device these values are reversed. See WFS preview window capture of the same watchface below.

World Time Test_1689591197682

As I already wrote, I do not use version 1.4.20. In version 1.3.13 everything is okay.


Version 1.3.13

I have now installed version 1.4.20.
Here I also inserted a complication line and everything is perfect. You made a mistake somewhere.

Version 1.4.20

Make a screenshot from the settings in WFS

Thanks. As you say, it all looks correct on the WFS 1.4.20 preview window, but you see the problem when you download the watchface onto your device.

WFS screenshot below - all looks OK.

Screenshot from the watch device below shows 24:xx


Yes, I just tested it. That’s right …


Screen Watch

I’ve raised a couple of bug reports.

#47096 and #47098

I don’t believe this is a WFS issue but the World Clock complication issue. Does the world clock on your mobile have the 24xx or is it correct?

You can find tons of reports of errors with the World Clock clear back to Galaxy Watch Studio time.

I’ll look into your bug reports

Samsung Developer Relations

If you want to have it right download Complication Suite and use one of the world clocks from that.

Samsung Developer Relations

Thanks Ron,

On my mobile, the world clock time is displayed correctly.

I’ll take a look at the complication suite.

Best Rgds

Well if it is working right in Complication Suite we will know it is not WFS :slight_smile:

Thanks Ron

Hello, I am from Germany and have the same problem.
I do not use a world time. I have the problem with the normal time field.
In an older version of the WFS it worked well. I noticed the problem a few month ago.
Is there any solution?

1 Like

Yes. German World Clock Time is definitely buggy with the the Watch Complication.
In Germany doesn’t exist a time like 24:23. It should be 0:23.


So when WFS is not responsible, who is?
Watch Software (Samsung)?
Wear OS?

The person that wrote the complication
The time standard has two ways to express the hour
0-23 and 1 - 24

Samsung Developer Relations

But who should I contact? The complication is pre-installed and is listed in the “watch section”. I therefore assume that only Samsung can fix the problem.

Unless it is part of the “Wear OS” standard. But in that case it would probably be listed in the “Standard section”.

Does anyone know if this is just Samsung Watch or if happens in the Pixel Watch or not? If it is only Samsung I can create a bug report but it if it is in all Wear OS then that is something else.

Samsung Developer Relations

@amoledwatchfaces Complication Suite has the world clock with the correct format.

This is gw 5 pro.

So in app its correct format. But on the face os wrong btw

Hi the time element?

Change the tag on the text field to used


The default was


I doubt the problem just appeared from nowhere its always default to [HOUR_1_12_Z]

So if you didnt change anything it will be 12:00 a.m instead of 00:00 or 24:00 every since.

Anyway change it to [HOUR_0_23]

Please note that I raised a bug report on this in July 2023 - #47096, which is currently ‘under review’